Apple Configurator 2.9 beta

Apple Configurator 2.9 beta

Apple Configurator 2.9 beta for use with macOS 10.14 or later

Download